Marri Devender Rao | 5a0088c | 2017-07-26 02:11:32 -0500 | [diff] [blame] | 1 | SUMMARY = "To merge the Host and BMC config files generated from MRW " |
| 2 | DESCRIPTION = "Merge host provided FRU info config file and \ |
| 3 | BMC accessible FRU info config files generated by \ |
| 4 | gen-ipmi-fru.pl into a single config file. fru-gen parser \ |
| 5 | parses the merged config file and generates cpp file" |
| 6 | PR = "r1" |
| 7 | |
| 8 | inherit native |
| 9 | inherit phosphor-ipmi-host |
| 10 | inherit obmc-phosphor-license |
| 11 | |
| 12 | DEPENDS += "virtual/phosphor-ipmi-fru-read-inventory" |
| 13 | DEPENDS += "virtual/phosphor-ipmi-fru-read-bmc-inventory" |
| 14 | PROVIDES += "virtual/phosphor-ipmi-fru-merge-config" |
| 15 | |
| 16 | do_install_append() { |
| 17 | SRC=${config_datadir} |
| 18 | DEST=${D}${config_datadir} |
| 19 | install -d ${DEST} |
| 20 | cat ${SRC}/config.yaml ${SRC}/bmc-fru-config.yaml > ${DEST}/fru_config.yaml |
| 21 | } |