blob: 806f07ca578befcd9602e90208e7b76e02ed2a61 [file] [log] [blame]
Matt Spinler3578d902018-06-21 14:23:47 -05001SUMMARY = "Copy error yaml files to known path for elog parsing"
2PR = "r1"
Patrick Venturef41f2172018-10-26 08:57:14 -07003PV = "1.0+git${SRCPV}"
Matt Spinler3578d902018-06-21 14:23:47 -05004LICENSE = "Apache-2.0"
Brad Bishopa1cee092019-09-13 12:14:05 -04005LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
Matt Spinler3578d902018-06-21 14:23:47 -05006
7inherit native
8inherit phosphor-dbus-yaml
9
10require phosphor-software-manager.inc
11
12S = "${WORKDIR}/git"
13
14do_install_append() {
15 SRC=${S}/xyz/openbmc_project/Software/
16 DEST=${D}${yaml_dir}/xyz/openbmc_project/Software/
17 install -d ${DEST}
18 install ${SRC}/*.errors.yaml ${DEST}
19 install ${SRC}/*.metadata.yaml ${DEST}
20}