Patrick Williams | 267c0bb | 2017-01-19 21:20:46 -0600 | [diff] [blame] | 1 | SUMMARY = "Phosphor State Management" |
| 2 | DESCRIPTION = "Phosphor State Manager provides a set of system state \ |
| 3 | management daemons. It is suitable for use on a wide variety of OpenBMC \ |
| 4 | platforms." |
| 5 | HOMEPAGE = "https://github.com/openbmc/phosphor-state-manager" |
| 6 | PR = "r1" |
| 7 | LICENSE = "Apache-2.0" |
| 8 | LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e" |
| 9 | |
| 10 | STATE_MGR_PACKAGES = " \ |
| 11 | ${PN}-host \ |
| 12 | ${PN}-chassis \ |
Josh King | a946288 | 2017-01-19 14:04:03 -0600 | [diff] [blame] | 13 | ${PN}-bmc \ |
Patrick Williams | 267c0bb | 2017-01-19 21:20:46 -0600 | [diff] [blame] | 14 | " |
| 15 | PACKAGES =+ "${STATE_MGR_PACKAGES}" |
Brad Bishop | c3f1057 | 2017-03-01 16:08:45 -0500 | [diff] [blame] | 16 | PACKAGES_remove = "${PN}" |
| 17 | RDEPENDS_${PN}-dev = "${STATE_MGR_PACKAGES}" |
| 18 | RDEPENDS_${PN}-staticdev = "${STATE_MGR_PACKAGES}" |
| 19 | |
Patrick Williams | 267c0bb | 2017-01-19 21:20:46 -0600 | [diff] [blame] | 20 | DBUS_PACKAGES = "${STATE_MGR_PACKAGES}" |
| 21 | |
| 22 | # Set SYSTEMD_PACKAGES to empty because we do not want ${PN} and DBUS_PACKAGES |
| 23 | # handles the rest. |
| 24 | SYSTEMD_PACKAGES = "" |
| 25 | |
| 26 | inherit autotools pkgconfig |
| 27 | inherit obmc-phosphor-dbus-service |
| 28 | |
| 29 | DEPENDS += "autoconf-archive-native" |
| 30 | DEPENDS += "sdbusplus" |
| 31 | DEPENDS += "phosphor-logging" |
Patrick Williams | d0486d8 | 2017-01-30 11:06:16 -0600 | [diff] [blame] | 32 | DEPENDS += "phosphor-dbus-interfaces" |
Adriana Kobylak | a6fc67f | 2017-01-30 20:30:00 -0600 | [diff] [blame] | 33 | RDEPENDS_${PN} += "sdbusplus" |
Patrick Williams | 267c0bb | 2017-01-19 21:20:46 -0600 | [diff] [blame] | 34 | |
Patrick Williams | d0486d8 | 2017-01-30 11:06:16 -0600 | [diff] [blame] | 35 | RDEPENDS_${PN}-host += "libsystemd phosphor-dbus-interfaces" |
| 36 | RDEPENDS_${PN}-chassis += "libsystemd phosphor-dbus-interfaces" |
| 37 | RDEPENDS_${PN}-bmc += "libsystemd phosphor-dbus-interfaces" |
Patrick Williams | 267c0bb | 2017-01-19 21:20:46 -0600 | [diff] [blame] | 38 | |
Patrick Williams | 267c0bb | 2017-01-19 21:20:46 -0600 | [diff] [blame] | 39 | FILES_${PN}-host = "${sbindir}/phosphor-host-state-manager" |
| 40 | DBUS_SERVICE_${PN}-host += "xyz.openbmc_project.State.Host.service" |
| 41 | |
Patrick Williams | 267c0bb | 2017-01-19 21:20:46 -0600 | [diff] [blame] | 42 | FILES_${PN}-chassis = "${sbindir}/phosphor-chassis-state-manager" |
| 43 | DBUS_SERVICE_${PN}-chassis += "xyz.openbmc_project.State.Chassis.service" |
| 44 | |
Josh King | a946288 | 2017-01-19 14:04:03 -0600 | [diff] [blame] | 45 | FILES_${PN}-bmc = "${sbindir}/phosphor-bmc-state-manager" |
| 46 | DBUS_SERVICE_${PN}-bmc += "xyz.openbmc_project.State.BMC.service" |
| 47 | |
Patrick Williams | 267c0bb | 2017-01-19 21:20:46 -0600 | [diff] [blame] | 48 | SRC_URI += "git://github.com/openbmc/phosphor-state-manager" |
Patrick Williams | e111782 | 2017-03-02 13:20:03 -0600 | [diff] [blame] | 49 | SRCREV = "2b5d887852c228ceb3cf2a89521498b596954ff9" |
Patrick Williams | 267c0bb | 2017-01-19 21:20:46 -0600 | [diff] [blame] | 50 | |
| 51 | S = "${WORKDIR}/git" |