blob: 76da1b56af64fc443237e079a8fe3db7f82e3af3 [file] [log] [blame]
Vishwanatha Subbanna04898332017-01-09 16:02:27 +05301SUMMARY = "Phosphor Physical LED Controller daemon"
2DESCRIPTION = "Daemon to trigger actions on a physical LED"
3HOMEPAGE = "http://github.com/openbmc/phosphor-led-sysfs"
4PR = "r1"
5
6LICENSE = "Apache-2.0"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
8inherit autotools pkgconfig
Brad Bishop66038f42017-01-26 12:36:52 -05009inherit obmc-phosphor-dbus-service
Vishwanatha Subbanna04898332017-01-09 16:02:27 +053010
11DEPENDS += "autoconf-archive-native"
12DEPENDS += "sdbusplus"
Xo Wange867f292017-03-14 16:40:31 -070013DEPENDS += "phosphor-dbus-interfaces"
Vishwanatha Subbanna04898332017-01-09 16:02:27 +053014RDEPENDS_${PN} += "libsystemd"
15
Brad Bishop66038f42017-01-26 12:36:52 -050016DBUS_SERVICE_${PN} += "xyz.openbmc_project.led.controller@.service"
17
Vishwanatha Subbanna04898332017-01-09 16:02:27 +053018SRC_URI += "git://github.com/openbmc/phosphor-led-sysfs"
Brad Bishop66038f42017-01-26 12:36:52 -050019SRC_URI += "file://70-leds.rules"
Andrew Geissler0222fb82018-08-01 08:55:05 -050020SRCREV = "8609c65aaa48eeff85cd9dd375253d7755581993"
Vishwanatha Subbanna04898332017-01-09 16:02:27 +053021S = "${WORKDIR}/git"
Brad Bishop66038f42017-01-26 12:36:52 -050022
23do_install_append() {
24 install -d ${D}/${base_libdir}/udev/rules.d/
25 install ${WORKDIR}/70-leds.rules ${D}/${base_libdir}/udev/rules.d/
26}