blob: 1446a73131356f1436e4f41f16b9cfc29c96bb76 [file] [log] [blame]
Brad Bishop9b1417f2015-09-21 17:16:16 -04001SUMMARY = "Phosphor OpenBMC BSP Example Application"
2DESCRIPTION = "Phosphor OpenBMC QEMU BSP example implementation."
3PR = "r1"
4
5DBUS_SERVICES = " \
6 org.openbmc.examples.PythonService0 \
7 org.openbmc.examples.PythonService1 \
8 "
9
10inherit obmc-phosphor-pydbus-service
Brad Bishopb2571e22015-09-21 22:01:13 -040011
12client = "pyclient-sample"
13SRC_URI += "file://${client}.py"
Brad Bishopdb6cd1b2015-10-18 22:00:15 -040014SRC_URI += "file://${PN}.py"
15S = "${WORKDIR}"
Brad Bishopb2571e22015-09-21 22:01:13 -040016
17do_install_append() {
18 install -d ${D}${bindir}
Brad Bishopdb6cd1b2015-10-18 22:00:15 -040019 install -m 0755 ${S}/${client}.py ${D}${bindir}/${client}
Brad Bishopb2571e22015-09-21 22:01:13 -040020}