Patrick Venture | 30823b2 | 2018-03-30 11:23:16 -0700 | [diff] [blame] | 1 | SUMMARY = "Phosphor OpenBMC Post Code Daemon" |
| 2 | DESCRIPTION = "Phosphor OpenBMC Post Code Daemon" |
Patrick Venture | a9ac4e5 | 2018-09-28 19:21:26 -0700 | [diff] [blame] | 3 | HOMEPAGE = "http://github.com/openbmc/phosphor-host-postd" |
Patrick Venture | 30823b2 | 2018-03-30 11:23:16 -0700 | [diff] [blame] | 4 | PR = "r1" |
Patrick Venture | a9ac4e5 | 2018-09-28 19:21:26 -0700 | [diff] [blame] | 5 | PV = "0.1+git${SRCPV}" |
| 6 | LICENSE = "Apache-2.0" |
| 7 | LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327" |
Patrick Venture | 30823b2 | 2018-03-30 11:23:16 -0700 | [diff] [blame] | 8 | |
| 9 | inherit autotools pkgconfig |
| 10 | inherit obmc-phosphor-systemd |
| 11 | |
| 12 | DEPENDS += "autoconf-archive-native" |
| 13 | DEPENDS += "sdbusplus" |
Kun Yi | cf49244 | 2018-09-12 11:01:33 -0700 | [diff] [blame] | 14 | DEPENDS += "sdeventplus" |
Patrick Venture | 30823b2 | 2018-03-30 11:23:16 -0700 | [diff] [blame] | 15 | DEPENDS += "phosphor-dbus-interfaces" |
| 16 | DEPENDS += "systemd" |
| 17 | |
Patrick Venture | a9ac4e5 | 2018-09-28 19:21:26 -0700 | [diff] [blame] | 18 | S = "${WORKDIR}/git" |
| 19 | SRC_URI = "git://github.com/openbmc/phosphor-host-postd" |
Andrew Geissler | a0e952b | 2018-11-02 21:10:21 +0000 | [diff] [blame] | 20 | SRCREV = "14c5d6f7aff84c23d641b2add6f3d2c95743c508" |
Patrick Venture | a9ac4e5 | 2018-09-28 19:21:26 -0700 | [diff] [blame] | 21 | |
Benjamin Fair | 8c605cf | 2018-06-29 13:00:14 -0700 | [diff] [blame] | 22 | SNOOP_DEVICE ?= "aspeed-lpc-snoop0" |
| 23 | POST_CODE_BYTES ?= "1" |
| 24 | |
| 25 | SERVICE_FILE = "lpcsnoop.service" |
| 26 | SYSTEMD_SERVICE_${PN} += "${SERVICE_FILE}" |
| 27 | SYSTEMD_SUBSTITUTIONS += "SNOOP_DEVICE:${SNOOP_DEVICE}:${SERVICE_FILE}" |
| 28 | SYSTEMD_SUBSTITUTIONS += "POST_CODE_BYTES:${POST_CODE_BYTES}:${SERVICE_FILE}" |