Ed Tanous | 69e46c2 | 2020-08-17 15:16:39 -0700 | [diff] [blame] | 1 | #This is largely to improve our build times by not building or installing |
Andrew Geissler | 3ee1f9d | 2020-11-03 08:16:37 -0600 | [diff] [blame] | 2 | #modules that OpenBMC does not use by our coding standard. Another thing to |
| 3 | #note is that for most targets, coroutine and context libraries are also added |
| 4 | #with a BOOST_LIBS_append_<platform> for most targets. Chrono/Thread should not |
| 5 | #be relied directly, but are required dependencies of context and coroutine. |
| 6 | #See the relevant portion of the openbmc coding standard with regards to boost |
| 7 | #libraries |
Ed Tanous | 69e46c2 | 2020-08-17 15:16:39 -0700 | [diff] [blame] | 8 | # |
| 9 | #https://github.com/openbmc/docs/blob/master/cpp-style-and-conventions.md#boost |
| 10 | # |
Andrew Geissler | 3ee1f9d | 2020-11-03 08:16:37 -0600 | [diff] [blame] | 11 | #BOOST_LIBS_openbmc-phosphor = "chrono thread" |
Ed Tanous | 69e46c2 | 2020-08-17 15:16:39 -0700 | [diff] [blame] | 12 | |