blob: 5fdc141f50b248ce701adf41d4877c4406365979 [file] [log] [blame]
Brad Bishop80fac6d2016-06-07 16:25:54 -04001SUMMARY = "U-Boot bootloader image creation tool"
2LICENSE = "GPLv2+"
3LIC_FILES_CHKSUM = "file://Licenses/README;md5=a2c678cfd4a4d97135585cad908541c6"
4SECTION = "bootloader"
5
6DEPENDS = "openssl"
7
Joel Stanleyc3c01472016-12-19 13:33:29 +10308SRCREV = "aa7a90f2ff1e807e057c6dbb0d0c579174c75acc"
Joel Stanley7741d652016-07-27 18:33:40 +09309UBRANCH = "v2016.07-aspeed-openbmc"
Brad Bishop80fac6d2016-06-07 16:25:54 -040010SRC_URI = "git://git@github.com/openbmc/u-boot.git;branch=${UBRANCH};protocol=https"
11
Joel Stanley7741d652016-07-27 18:33:40 +093012PV = "v2016.07+git${SRCPV}"
Brad Bishop80fac6d2016-06-07 16:25:54 -040013
14S = "${WORKDIR}/git"
15
16EXTRA_OEMAKE = 'CROSS_COMPILE="${TARGET_PREFIX}" CC="${CC} ${CFLAGS} ${LDFLAGS}" STRIP=true V=1'
17
18do_compile () {
19 oe_runmake sandbox_defconfig
20 oe_runmake cross_tools NO_SDL=1
21}
22
23do_install () {
24 install -d ${D}${bindir}
25 install -m 0755 tools/mkimage ${D}${bindir}/uboot-mkimage
26 ln -sf uboot-mkimage ${D}${bindir}/mkimage
27}
28
29BBCLASSEXTEND = "native nativesdk"