blob: 03ed8d61f0d9b8c46dfd03cbcd8494cab2f7d0d4 [file] [log] [blame]
Vijay Khemka4d2032e2020-07-23 15:22:56 -07001SUMMARY = "BMC Health Monitoring"
2DESCRIPTION = "Daemon to collect and monitor bmc health statistics"
3HOMEPAGE = "https://github.com/openbmc/phosphor-health-monitor"
4PR = "r1"
5LICENSE = "Apache-2.0"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=9e69ba356fa59848ffd865152a3ccc13"
7
8inherit meson pkgconfig
9inherit systemd
10
11DEPENDS += "sdbusplus"
12DEPENDS += "phosphor-dbus-interfaces"
13DEPENDS += "sdeventplus"
14DEPENDS += "phosphor-logging"
15DEPENDS += "nlohmann-json"
16
17SRC_URI = "git://github.com/openbmc/phosphor-health-monitor.git;protocol=git"
Andrew Geisslerf6571ab2020-10-01 19:11:15 +000018SRCREV = "1d0d012063f962dae3b8ab06f31c7e23559673f8"
Vijay Khemka4d2032e2020-07-23 15:22:56 -070019S = "${WORKDIR}/git"
20
21SYSTEMD_SERVICE_${PN} = "phosphor-health-monitor.service"