Vishwanatha Subbanna | 0489833 | 2017-01-09 16:02:27 +0530 | [diff] [blame] | 1 | SUMMARY = "Phosphor Physical LED Controller daemon" |
| 2 | DESCRIPTION = "Daemon to trigger actions on a physical LED" |
| 3 | HOMEPAGE = "http://github.com/openbmc/phosphor-led-sysfs" |
| 4 | PR = "r1" |
Patrick Venture | 1f52b4e | 2018-10-02 20:54:25 -0700 | [diff] [blame] | 5 | PV = "1.0+git${SRCPV}" |
Vishwanatha Subbanna | 0489833 | 2017-01-09 16:02:27 +0530 | [diff] [blame] | 6 | LICENSE = "Apache-2.0" |
| 7 | LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e" |
Patrick Venture | 1f52b4e | 2018-10-02 20:54:25 -0700 | [diff] [blame] | 8 | |
Vishwanatha Subbanna | 0489833 | 2017-01-09 16:02:27 +0530 | [diff] [blame] | 9 | inherit autotools pkgconfig |
Brad Bishop | 66038f4 | 2017-01-26 12:36:52 -0500 | [diff] [blame] | 10 | inherit obmc-phosphor-dbus-service |
Vishwanatha Subbanna | 0489833 | 2017-01-09 16:02:27 +0530 | [diff] [blame] | 11 | |
| 12 | DEPENDS += "autoconf-archive-native" |
| 13 | DEPENDS += "sdbusplus" |
Brad Bishop | 26873c9 | 2019-03-22 23:41:42 -0400 | [diff] [blame] | 14 | DEPENDS += "systemd" |
Xo Wang | e867f29 | 2017-03-14 16:40:31 -0700 | [diff] [blame] | 15 | DEPENDS += "phosphor-dbus-interfaces" |
Andrew Geissler | 113bfcd | 2019-06-25 02:12:26 +0000 | [diff] [blame] | 16 | DEPENDS += "boost" |
Vishwanatha Subbanna | 0489833 | 2017-01-09 16:02:27 +0530 | [diff] [blame] | 17 | |
Brad Bishop | 66038f4 | 2017-01-26 12:36:52 -0500 | [diff] [blame] | 18 | DBUS_SERVICE_${PN} += "xyz.openbmc_project.led.controller@.service" |
| 19 | |
Vishwanatha Subbanna | 0489833 | 2017-01-09 16:02:27 +0530 | [diff] [blame] | 20 | SRC_URI += "git://github.com/openbmc/phosphor-led-sysfs" |
Brad Bishop | 66038f4 | 2017-01-26 12:36:52 -0500 | [diff] [blame] | 21 | SRC_URI += "file://70-leds.rules" |
Andrew Geissler | 439ea91 | 2020-06-03 00:31:21 +0000 | [diff] [blame] | 22 | SRCREV = "604a45ea783b5a5646a5950240a5b95611263587" |
Vishwanatha Subbanna | 0489833 | 2017-01-09 16:02:27 +0530 | [diff] [blame] | 23 | S = "${WORKDIR}/git" |
Brad Bishop | 66038f4 | 2017-01-26 12:36:52 -0500 | [diff] [blame] | 24 | |
| 25 | do_install_append() { |
| 26 | install -d ${D}/${base_libdir}/udev/rules.d/ |
Brad Bishop | d0c97c0 | 2019-11-14 14:37:51 -0500 | [diff] [blame] | 27 | install -m 0644 ${WORKDIR}/70-leds.rules ${D}/${base_libdir}/udev/rules.d/ |
Brad Bishop | 66038f4 | 2017-01-26 12:36:52 -0500 | [diff] [blame] | 28 | } |