Matt Spinler | c943de3 | 2017-03-21 15:02:13 -0500 | [diff] [blame] | 1 | SUMMARY = "Generate fan presence YAML from the MRW" |
| 2 | PR = "r1" |
| 3 | |
| 4 | inherit native |
| 5 | inherit obmc-phosphor-license |
| 6 | inherit phosphor-fan-presence |
| 7 | |
| 8 | DEPENDS += " \ |
| 9 | mrw-native \ |
| 10 | mrw-perl-tools-native \ |
| 11 | " |
| 12 | |
| 13 | PROVIDES += "virtual/phosphor-fan-presence-config" |
| 14 | |
| 15 | S = "${WORKDIR}" |
| 16 | |
| 17 | do_install() { |
| 18 | DEST=${D}${presence_datadir} |
| 19 | install -d ${DEST} |
| 20 | |
| 21 | ${bindir}/perl-native/perl \ |
| 22 | ${bindir}/gen_presence_yaml.pl \ |
| 23 | -i ${datadir}/obmc-mrw/${MACHINE}.xml \ |
| 24 | -o ${DEST}/config.yaml |
| 25 | } |