blob: 0c3db174b95f996b2d773cb2fa55a4b47a039ceb [file] [log] [blame]
Chris Austen213cd2a2015-10-24 19:34:11 -05001SUMMARY = "Phosphor OpenBMC OEM Commands for OpenPOWER systems"
2DESCRIPTION = "Phosphor OpenBMC IPMI OEM commands for OpenPOWER based systems"
3HOMEPAGE = "https://github.com/openbmc/openpower-host-ipmi-oem"
4PR = "r1"
5
6RRECOMMENDS_${PN} = "virtual/obmc-phosphor-host-ipmi-hw"
7
8inherit obmc-phosphor-license
9
10DEPENDS += "systemd \
11 host-ipmid \
12 "
13
14
15RDEPENDS_${PN} += "libsystemd"
16
17
18
19SRC_URI += "git://github.com/openbmc/openpower-host-ipmi-oem"
20
Chris Austen8708d462015-10-30 15:33:24 -050021SRCREV = "17160cebf1735337a35a12ba27728d90c5207ec5"
Chris Austen213cd2a2015-10-24 19:34:11 -050022
23FILES_${PN} += "${libdir}/host-ipmid/*.so"
24FILES_${PN}-dbg += "${libdir}/host-ipmid/.debug"
25
26S = "${WORKDIR}/git"
27
28do_install() {
29 install -m 0755 -d ${D}${libdir}/host-ipmid
30 install -m 0755 ${S}/*.so ${D}${libdir}/host-ipmid/
31}