blob: f5375c4a929cd244bccdda98071df8374fcbdd2d [file] [log] [blame]
Adriana Kobylakfa7c2122015-10-19 14:15:04 -04001SUMMARY = "Temp placeholder for skeleton function"
2DESCRIPTION = "Temp placeholder for skeleton repository"
3HOMEPAGE = "http://github.com/openbmc/skeleton"
4PR = "r1"
5
6inherit obmc-phosphor-license
7inherit obmc-phosphor-systemd
8
9DEPENDS += "glib-2.0"
Brad Bishopd1e4e3f2015-10-19 14:22:57 -040010RDEPENDS_${PN} += "python-subprocess python-tftpy"
Adriana Kobylakfa7c2122015-10-19 14:15:04 -040011SRC_URI += "git://github.com/openbmc/skeleton"
Brad Bishop30365d82015-10-19 14:16:40 -040012SRC_URI += "file://make.patch"
Adriana Kobylakfa7c2122015-10-19 14:15:04 -040013
14SRCREV = "18d4591170779ceb81158c650d31c6c59115b2f2"
15
16S = "${WORKDIR}/git"
17
18do_compile() {
19 oe_runmake all
20}
21
22do_install() {
23 install -d ${D}/${sbindir} ${D}${libdir}
Brad Bishopd1e4e3f2015-10-19 14:22:57 -040024 for i in ${S}/bin/*.py ${S}/bin/*.exe; do
Adriana Kobylakfa7c2122015-10-19 14:15:04 -040025 install $i ${D}/${sbindir}
26 done
27 install ${S}/bin/libopenbmc_intf.so ${D}/${libdir}
28}