Brad Bishop | f1cc41b | 2017-05-31 14:08:33 -0400 | [diff] [blame] | 1 | SUMMARY = "Phosphor DBus Monitor" |
| 2 | DESCRIPTION = "Phosphor DBus Monitor is a general purpose DBus application \ |
| 3 | that watches DBus traffic for events and takes actions based on those events." |
| 4 | PR = "r1" |
| 5 | |
| 6 | HOMEPAGE = "http://github.com/openbmc/phosphor-dbus-monitor" |
| 7 | LICENSE = "Apache-2.0" |
| 8 | LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e" |
| 9 | SRC_URI = "git://github.com/openbmc/phosphor-dbus-monitor" |
Andrew Geissler | 5751762 | 2018-10-04 20:30:17 +0000 | [diff] [blame] | 10 | SRCREV = "8e273775ee53d796c9accd256aac7c5dd9562b21" |
Brad Bishop | f1cc41b | 2017-05-31 14:08:33 -0400 | [diff] [blame] | 11 | |
| 12 | inherit autotools \ |
| 13 | pkgconfig \ |
| 14 | pythonnative \ |
| 15 | phosphor-dbus-monitor \ |
| 16 | obmc-phosphor-systemd |
| 17 | |
Brad Bishop | eafda3b | 2017-08-02 01:32:43 -0400 | [diff] [blame] | 18 | PACKAGE_BEFORE_PN = "phosphor-msl-verify" |
| 19 | SYSTEMD_PACKAGES = "${PN} phosphor-msl-verify" |
| 20 | SYSTEMD_SERVICE_phosphor-msl-verify = "phosphor-msl-verify.service" |
| 21 | |
Brad Bishop | f1cc41b | 2017-05-31 14:08:33 -0400 | [diff] [blame] | 22 | DEPENDS += " \ |
| 23 | ${PN}-config-native \ |
| 24 | phosphor-logging \ |
| 25 | autoconf-archive-native \ |
Brad Bishop | f06d3b6 | 2018-01-26 21:48:20 -0500 | [diff] [blame] | 26 | sdbusplus-native \ |
Brad Bishop | f1cc41b | 2017-05-31 14:08:33 -0400 | [diff] [blame] | 27 | gtest \ |
Andrew Geissler | 7615800 | 2018-09-05 00:30:15 +0000 | [diff] [blame] | 28 | phosphor-snmp \ |
Brad Bishop | f1cc41b | 2017-05-31 14:08:33 -0400 | [diff] [blame] | 29 | " |
| 30 | RDEPENDS_${PN} += " \ |
| 31 | sdbusplus \ |
| 32 | phosphor-dbus-interfaces \ |
| 33 | phosphor-logging \ |
Andrew Geissler | 7615800 | 2018-09-05 00:30:15 +0000 | [diff] [blame] | 34 | phosphor-snmp \ |
Brad Bishop | f1cc41b | 2017-05-31 14:08:33 -0400 | [diff] [blame] | 35 | " |
| 36 | |
Brad Bishop | eafda3b | 2017-08-02 01:32:43 -0400 | [diff] [blame] | 37 | RDEPENDS_phosphor-msl-verify += " \ |
| 38 | sdbusplus \ |
| 39 | phosphor-dbus-interfaces \ |
| 40 | phosphor-logging \ |
Andrew Geissler | 7615800 | 2018-09-05 00:30:15 +0000 | [diff] [blame] | 41 | phosphor-snmp \ |
Brad Bishop | eafda3b | 2017-08-02 01:32:43 -0400 | [diff] [blame] | 42 | " |
| 43 | FILES_phosphor-msl-verify = "${sbindir}/phosphor-msl-verify" |
| 44 | |
Brad Bishop | f1cc41b | 2017-05-31 14:08:33 -0400 | [diff] [blame] | 45 | S = "${WORKDIR}/git" |
| 46 | |
| 47 | EXTRA_OECONF = " \ |
| 48 | YAML_PATH=${STAGING_DIR_NATIVE}${config_dir} \ |
| 49 | " |