Patrick Venture | db1cc9b | 2018-09-20 19:27:13 -0700 | [diff] [blame] | 1 | HOMEPAGE = "http://github.com/openbmc/phosphor-ipmi-blobs" |
| 2 | SUMMARY = "Phosphor OEM IPMI BLOBS Protocol Implementation" |
| 3 | DESCRIPTION = "This package handles a series of OEM IPMI commands that implement the BLOB protocol for sending and receiving data over IPMI." |
| 4 | PR = "r1" |
| 5 | PV = "0.1+git${SRCPV}" |
| 6 | LICENSE = "Apache-2.0" |
| 7 | LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327" |
| 8 | |
| 9 | inherit autotools pkgconfig |
| 10 | inherit obmc-phosphor-ipmiprovider-symlink |
| 11 | |
| 12 | DEPENDS += "autoconf-archive-native" |
| 13 | DEPENDS += "phosphor-ipmi-host" |
Patrick Venture | 2b12094 | 2018-09-27 12:56:49 -0700 | [diff] [blame] | 14 | DEPENDS += "phosphor-logging" |
Patrick Venture | a007bef | 2019-03-07 10:53:50 -0800 | [diff] [blame] | 15 | DEPENDS += "ipmi-blob-tool" |
Patrick Venture | db1cc9b | 2018-09-20 19:27:13 -0700 | [diff] [blame] | 16 | |
| 17 | S = "${WORKDIR}/git" |
| 18 | SRC_URI = "git://github.com/openbmc/phosphor-ipmi-blobs" |
Andrew Geissler | ff015fe | 2019-03-20 21:12:07 +0000 | [diff] [blame] | 19 | SRCREV = "924bc380c47f33689a1243b2d79cb619674c86fa" |
Patrick Venture | db1cc9b | 2018-09-20 19:27:13 -0700 | [diff] [blame] | 20 | |
| 21 | FILES_${PN}_append = " ${libdir}/ipmid-providers/lib*${SOLIBS}" |
| 22 | FILES_${PN}_append = " ${libdir}/host-ipmid/lib*${SOLIBS}" |
| 23 | FILES_${PN}_append = " ${libdir}/net-ipmid/lib*${SOLIBS}" |
| 24 | FILES_${PN}-dev_append = " ${libdir}/ipmid-providers/lib*${SOLIBSDEV} ${libdir}/ipmid-providers/*.la" |
| 25 | |
| 26 | HOSTIPMI_PROVIDER_LIBRARY += "libblobcmds.so" |