blob: c94da304c34aa01f67c2d5d8e2ccd8586f618320 [file] [log] [blame]
Matt Spinlerd78cb462016-10-17 11:20:01 -05001SUMMARY = "Phosphor Device Tree Generator"
2DESCRIPTION = "Script to generate the BMC device tree from the MRW XML"
3PR = "r1"
4
5S = "${WORKDIR}/git"
6
7inherit obmc-phosphor-license
8inherit native
9inherit mrw-rev
10
11DEPENDS += "yaml-tiny mrw-api-native"
12
13SRC_URI += "${MRW_TOOLS_SRC_URI}"
14SRCREV = "${MRW_TOOLS_SRCREV}"
15
16do_install() {
17 install -d ${D}${STAGING_BINDIR_NATIVE}
18 install -m 0755 gen_devtree.pl ${D}${STAGING_BINDIR_NATIVE}/gen_devtree.pl
19}