blob: 68ee00d20ad1edb25191dc2dc5d79b7c8664ef07 [file] [log] [blame]
Milton D. Miller IId89d5e02016-01-20 14:57:54 -06001SUMMARY = "Phosphor OpenBMC pre-init scripts"
2DESCRIPTION = "Phosphor OpenBMC filesytem mount reference implementation."
3PR = "r1"
4
5inherit obmc-phosphor-license
6inherit obmc-phosphor-initfs
7
8S = "${WORKDIR}"
9SRC_URI += "file://obmc-init.sh"
10SRC_URI += "file://obmc-shutdown.sh"
11SRC_URI += "file://obmc-update.sh"
12SRC_URI += "file://whitelist"
13
14do_install() {
15 install -m 0755 ${WORKDIR}/obmc-init.sh ${D}/init
16 install -m 0755 ${WORKDIR}/obmc-shutdown.sh ${D}/shutdown
17 install -m 0755 ${WORKDIR}/obmc-update.sh ${D}/update
18 install -m 0644 ${WORKDIR}/whitelist ${D}/whitelist
19 install -d ${D}/dev
20 mknod -m 622 ${D}/dev/console c 5 1
21}
22
23FILES_${PN} += " /init /shutdown /update /whitelist /dev "