Brad Bishop | 595edcf | 2016-11-09 20:43:11 -0500 | [diff] [blame] | 1 | SUMMARY = "C++ bindings for systemd dbus APIs" |
| 2 | DESCRIPTION = "C++ bindings for systemd dbus APIs." |
| 3 | HOMEPAGE = "http://github.com/openbmc/sdbusplus" |
| 4 | PR = "r1" |
| 5 | LICENSE = "Apache-2.0" |
| 6 | LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e" |
| 7 | |
| 8 | inherit autotools pkgconfig |
| 9 | inherit pythonnative |
| 10 | |
| 11 | FILES_${PN} += "${PYTHON_SITEPACKAGES_DIR}" |
| 12 | |
| 13 | DEPENDS += "autoconf-archive-native" |
| 14 | RDEPENDS_${PN} += " \ |
| 15 | python-inflection \ |
| 16 | python-mako \ |
| 17 | python-pyyaml \ |
| 18 | " |
| 19 | |
| 20 | SRC_URI += "git://github.com/openbmc/sdbusplus" |
| 21 | SRCREV = "ccacc4af969a70cc24f84981b5a5dde01a928d09" |
| 22 | |
| 23 | PACKAGECONFIG ??= "libsdbusplus" |
| 24 | PACKAGECONFIG[libsdbusplus] = "--enable-libsdbusplus,--disable-libsdbusplus,systemd,libsystemd" |
| 25 | |
| 26 | S = "${WORKDIR}/git" |
| 27 | |
| 28 | PACKAGECONFIG_remove_class-native = "libsdbusplus" |
| 29 | PACKAGECONFIG_remove_class-nativesdk = "libsdbusplus" |
| 30 | |
| 31 | export BUILD_SYS |
| 32 | export HOST_SYS |
| 33 | export STAGING_INCDIR |
| 34 | export STAGING_LIBDIR |
| 35 | |
| 36 | BBCLASSEXTEND += "native nativesdk" |