Jeremy Kerr | 5c7f42e | 2019-12-20 12:02:36 +0800 | [diff] [blame] | 1 | SUMMARY = "MCTP stack" |
| 2 | DESCRIPTION = "MCTP library implementing the MCTP base specification" |
| 3 | PR = "r1" |
| 4 | PV = "1.0+git${SRCPV}" |
| 5 | |
| 6 | inherit systemd |
| 7 | inherit autotools pkgconfig |
| 8 | |
| 9 | HOMEPAGE = "https://github.com/openbmc/libmctp" |
| 10 | LICENSE = "Apache-2.0" |
| 11 | LIC_FILES_CHKSUM = "file://LICENSE;md5=0d30807bb7a4f16d36e96b78f9ed8fae" |
| 12 | SRC_URI = "git://github.com/openbmc/libmctp \ |
| 13 | file://default" |
| 14 | SRCREV = "34b9b3d82b049610775aea4460ff0f3bb9f02b1d" |
| 15 | CONFFILES_${PN} = "${sysconfdir}/default/mctp" |
| 16 | |
| 17 | DEPENDS += "autoconf-archive-native \ |
| 18 | systemd \ |
| 19 | " |
| 20 | |
| 21 | SYSTEMD_SERVICE_${PN} = "mctp-demux.service" |
| 22 | |
| 23 | do_install_append() { |
| 24 | install -d ${D}${sysconfdir}/default |
| 25 | install -m 0644 ${WORKDIR}/default ${D}${sysconfdir}/default/mctp |
| 26 | } |
| 27 | |
| 28 | S = "${WORKDIR}/git" |