Vishwanatha Subbanna | 7e84c6e | 2017-01-23 16:04:35 +0530 | [diff] [blame] | 1 | SUMMARY = "Phosphor LED Group Management with MRW generated data" |
| 2 | PR = "r1" |
Patrick Venture | 58b1537 | 2018-11-04 08:15:55 -0800 | [diff] [blame] | 3 | LICENSE = "Apache-2.0" |
Brad Bishop | a1cee09 | 2019-09-13 12:14:05 -0400 | [diff] [blame] | 4 | LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10" |
Vishwanatha Subbanna | 7e84c6e | 2017-01-23 16:04:35 +0530 | [diff] [blame] | 5 | |
| 6 | inherit native |
Matt Spinler | 3f6fcbe | 2017-12-14 13:31:55 -0600 | [diff] [blame] | 7 | inherit mrw-xml |
Vishwanatha Subbanna | 7e84c6e | 2017-01-23 16:04:35 +0530 | [diff] [blame] | 8 | |
Vishwanatha Subbanna | 8bec825 | 2017-02-11 22:10:23 +0530 | [diff] [blame] | 9 | PROVIDES += "virtual/phosphor-led-manager-config-native" |
Vishwanatha Subbanna | 7e84c6e | 2017-01-23 16:04:35 +0530 | [diff] [blame] | 10 | DEPENDS += "mrw-native mrw-perl-tools-native" |
| 11 | |
| 12 | # Generate a YAML files based on MRW input |
| 13 | do_install_append() { |
Brad Bishop | e00bf6f | 2019-05-14 12:25:34 -0400 | [diff] [blame] | 14 | USE_MRW="${@bb.utils.contains('DISTRO_FEATURES', 'obmc-mrw', 'yes', 'no', d)}" |
Patrick Williams | e81f8c0 | 2017-02-28 14:28:18 -0600 | [diff] [blame] | 15 | DEST=${D}${datadir}/phosphor-led-manager |
Vishwanatha Subbanna | 7e84c6e | 2017-01-23 16:04:35 +0530 | [diff] [blame] | 16 | |
| 17 | if [ "${USE_MRW}" = "yes" ]; then |
| 18 | install -d ${DEST}/ |
| 19 | ${STAGING_BINDIR_NATIVE}/perl-native/perl \ |
| 20 | ${STAGING_BINDIR_NATIVE}/gen_led_groups.pl \ |
Matt Spinler | 3f6fcbe | 2017-12-14 13:31:55 -0600 | [diff] [blame] | 21 | -i ${mrw_datadir}/${MRW_XML} \ |
Vishwanatha Subbanna | 7e84c6e | 2017-01-23 16:04:35 +0530 | [diff] [blame] | 22 | -o ${DEST}/led.yaml |
| 23 | fi |
| 24 | } |