Adriana Kobylak | 9fca92d | 2020-06-02 13:18:36 -0500 | [diff] [blame] | 1 | SUMMARY = "Miscellaneous OpenBMC functions" |
| 2 | HOMEPAGE = "https://github.com/openbmc/phosphor-misc" |
| 3 | LICENSE = "Apache-2.0" |
| 4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e" |
| 5 | PR = "r1" |
| 6 | PV = "1.0+git${SRCPV}" |
| 7 | |
| 8 | SRC_URI = "git://github.com/openbmc/phosphor-misc" |
Andrew Geissler | 67429d7 | 2020-10-08 16:41:28 +0000 | [diff] [blame] | 9 | SRCREV = "75d4734fb8bc390d97106544af8f2ffd2d9bf02c" |
Adriana Kobylak | 9fca92d | 2020-06-02 13:18:36 -0500 | [diff] [blame] | 10 | |
| 11 | S = "${WORKDIR}/git" |
| 12 | |
| 13 | inherit meson |
| 14 | inherit pkgconfig |
| 15 | inherit systemd |
| 16 | |
| 17 | DEPENDS = "systemd" |
| 18 | |
| 19 | PHOSPHOR_MISC_PACKAGES = " \ |
| 20 | ${@bb.utils.contains('PACKAGECONFIG', 'first-boot-set-hostname', '${PN}-first-boot-set-hostname', '', d)} \ |
| 21 | ${@bb.utils.contains('PACKAGECONFIG', 'first-boot-set-mac', '${PN}-first-boot-set-mac', '', d)} \ |
| 22 | ${@bb.utils.contains('PACKAGECONFIG', 'http-redirect-awk', '${PN}-http-redirect-awk', '', d)} \ |
| 23 | ${@bb.utils.contains('PACKAGECONFIG', 'usb-ctrl', '${PN}-usb-ctrl', '', d)} \ |
| 24 | " |
| 25 | |
| 26 | PACKAGES_remove = "${PN}" |
| 27 | RDEPENDS_${PN}-dev = "" |
| 28 | |
| 29 | PACKAGE_BEFORE_PN += "${PHOSPHOR_MISC_PACKAGES}" |
| 30 | SYSTEMD_PACKAGES = "${PHOSPHOR_MISC_PACKAGES}" |
| 31 | |
| 32 | PACKAGECONFIG ??= " \ |
| 33 | first-boot-set-hostname \ |
| 34 | first-boot-set-mac \ |
| 35 | http-redirect-awk \ |
| 36 | usb-ctrl \ |
| 37 | " |
| 38 | |
| 39 | PACKAGECONFIG[first-boot-set-hostname] = "-Dfirst-boot-set-hostname=enabled, -Dfirst-boot-set-hostname=disabled" |
| 40 | PACKAGECONFIG[first-boot-set-mac] = "-Dfirst-boot-set-mac=enabled, -Dfirst-boot-set-mac=disabled" |
| 41 | PACKAGECONFIG[http-redirect-awk] = "-Dhttp-redirect=enabled, -Dhttp-redirect=disabled" |
| 42 | PACKAGECONFIG[usb-ctrl] = "-Dusb-ctrl=enabled, -Dusb-ctrl=disabled" |
| 43 | |
| 44 | # first-boot-set-hostname |
| 45 | FILES_${PN}-first-boot-set-hostname = "${bindir}/first-boot-set-hostname.sh" |
| 46 | SYSTEMD_SERVICE_${PN}-first-boot-set-hostname = "first-boot-set-hostname.service" |
| 47 | |
| 48 | # first-boot-set-mac |
| 49 | FILES_${PN}-first-boot-set-mac = "${bindir}/first-boot-set-mac.sh" |
| 50 | SYSTEMD_SERVICE_${PN}-first-boot-set-mac = "first-boot-set-mac@.service" |
| 51 | |
| 52 | # http-redirect-awk |
| 53 | FILES_${PN}-http-redirect-awk = "${bindir}/http-redirect.awk" |
| 54 | SYSTEMD_SERVICE_${PN}-http-redirect-awk = " \ |
| 55 | http-redirect@.service \ |
| 56 | http-redirect.socket \ |
| 57 | " |
| 58 | RDEPENDS_${PN}-http-redirect-awk = "${VIRTUAL-RUNTIME_base-utils}" |
| 59 | |
| 60 | # usb-ctrl |
| 61 | FILES_${PN}-usb-ctrl = "${bindir}/usb-ctrl" |