Brad Bishop | 86ee1cf | 2016-06-27 14:53:52 -0400 | [diff] [blame] | 1 | SUMMARY = "org.openbmc.control.Host implementation for OpenPOWER" |
| 2 | DESCRIPTION = "A host control implementation suitable for OpenPOWER systems." |
| 3 | PR = "r1" |
| 4 | |
| 5 | inherit skeleton-gdbus |
Brad Bishop | 0fe8046 | 2016-08-17 20:27:37 -0400 | [diff] [blame] | 6 | inherit obmc-phosphor-dbus-service |
Brad Bishop | 86ee1cf | 2016-06-27 14:53:52 -0400 | [diff] [blame] | 7 | |
| 8 | SKELETON_DIR = "op-hostctl" |
Brad Bishop | 0fe8046 | 2016-08-17 20:27:37 -0400 | [diff] [blame] | 9 | |
| 10 | FMT = "org.openbmc.control.Host@{0}.service" |
| 11 | DBUS_SERVICE_${PN} += "${@compose_list(d, 'FMT', 'OBMC_HOST_INSTANCES')}" |
| 12 | SYSTEMD_SERVICE_${PN} = "op-start-host@.service" |
| 13 | |
| 14 | START_TMPL = "op-start-host@.service" |
| 15 | START_TGTFMT = "obmc-chassis-start@{1}.target" |
| 16 | START_INSTFMT = "obmc-start-host@{0}.service" |
| 17 | START_FMT = "../${START_TMPL}:${START_TGTFMT}.wants/${START_INSTFMT}" |
| 18 | |
| 19 | SYSTEMD_LINK_${PN} += "${@compose_list_zip(d, 'START_FMT', 'OBMC_HOST_INSTANCES', 'OBMC_CHASSIS_INSTANCES')}" |