blob: 70fad6313f22e815d165636537e4f1af6c35bde7 [file] [log] [blame]
Brad Bishop86ee1cf2016-06-27 14:53:52 -04001SUMMARY = "OpenBMC python devtools"
2DESCRIPTION = "Shortcut scripts for developers."
3PR = "r1"
4
5inherit skeleton-python
6
7VIRTUAL-RUNTIME_skeleton_workbook ?= ""
8
9RDEPENDS_${PN} += "\
10 python-dbus \
11 python-json \
12 python-xml \
13 python-pygobject \
14 ${VIRTUAL-RUNTIME_skeleton_workbook} \
15 "
16
17SKELETON_DIR = "pytools"
Andrew Jefferye6e3f462018-02-26 11:25:27 +103018
19do_install_append() {
20 if [ -f ${S}/obmcutil-completion.sh ]
21 then
22 install -m 0644 -D -t ${D}/${sysconfdir}/profile.d ${S}/obmcutil-completion.sh
23 fi
24}