blob: 7d4b81a31ca1a2e6aa79a6be22e06528cbf94d94 [file] [log] [blame]
Vishwanatha Subbanna7e84c6e2017-01-23 16:04:35 +05301SUMMARY = "Phosphor LED Group Management meta data"
2PR = "r1"
3
4inherit obmc-phosphor-utils
5inherit obmc-phosphor-license
6
7# Default is the example set of data.
8PHOSPHOR_LED_MANAGER_CONFIG ??= "${PN}-example-native"
9
10# Choose appropriate yaml file
11def get_depends(d):
12 if d.getVar('USE_MRW', 'yes'):
13 return "${PN}-mrw-native"
14 else:
15 return "${PHOSPHOR_LED_MANAGER_CONFIG}"
16
Brad Bishopb943d912017-01-31 10:37:13 -050017USE_MRW = "${@cf_enabled(d, 'obmc-mrw', 'yes')}"
Vishwanatha Subbanna7e84c6e2017-01-23 16:04:35 +053018DEPENDS += "${@get_depends(d)}"