blob: 894acdd882256b5f15829a3e278cab392f39c3bb [file] [log] [blame]
Vishwanatha Subbanna0f2b7b02017-10-18 15:47:54 +05301SUMMARY = "Phosphor User Manager Daemon"
2DESCRIPTION = "Daemon that does user management"
3HOMEPAGE = "http://github.com/openbmc/phosphor-user-manager"
4PR = "r1"
5
6LICENSE = "Apache-2.0"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
8inherit autotools pkgconfig
9inherit obmc-phosphor-dbus-service
10
11DEPENDS += "autoconf-archive-native"
12DEPENDS += "sdbusplus"
13DEPENDS += "phosphor-logging"
14DEPENDS += "phosphor-dbus-interfaces"
Tom Joseph1c1845e2018-07-10 12:23:06 -050015DEPENDS += "boost"
Vishwanatha Subbanna0f2b7b02017-10-18 15:47:54 +053016RDEPENDS_${PN} += "libsystemd"
17RDEPENDS_${PN} += "phosphor-logging"
18
Richard Marian Thomaiyar0aed5da2018-04-12 16:06:36 -070019inherit useradd
20
21USERADD_PACKAGES = "${PN}"
22# add groups needed for privilege maintenance
23GROUPADD_PARAM_${PN} = "priv-admin; priv-operator; priv-user; priv-callback "
Vishwanatha Subbanna0f2b7b02017-10-18 15:47:54 +053024
25DBUS_SERVICE_${PN} += "xyz.openbmc_project.User.Manager.service"
26
27SRC_URI += "git://github.com/openbmc/phosphor-user-manager"
Andrew Geisslere8810102018-10-04 19:30:29 +000028SRCREV = "dccee2b7ff47757afb6a0606707b6436bb0f4c7b"
Vishwanatha Subbanna0f2b7b02017-10-18 15:47:54 +053029S = "${WORKDIR}/git"