Vishwanatha Subbanna | 0489833 | 2017-01-09 16:02:27 +0530 | [diff] [blame] | 1 | SUMMARY = "Phosphor Physical LED Controller daemon" |
| 2 | DESCRIPTION = "Daemon to trigger actions on a physical LED" |
| 3 | HOMEPAGE = "http://github.com/openbmc/phosphor-led-sysfs" |
| 4 | PR = "r1" |
Patrick Venture | 1f52b4e | 2018-10-02 20:54:25 -0700 | [diff] [blame] | 5 | PV = "1.0+git${SRCPV}" |
Vishwanatha Subbanna | 0489833 | 2017-01-09 16:02:27 +0530 | [diff] [blame] | 6 | LICENSE = "Apache-2.0" |
| 7 | LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e" |
Patrick Venture | 1f52b4e | 2018-10-02 20:54:25 -0700 | [diff] [blame] | 8 | |
Vishwanatha Subbanna | 0489833 | 2017-01-09 16:02:27 +0530 | [diff] [blame] | 9 | inherit autotools pkgconfig |
Brad Bishop | 66038f4 | 2017-01-26 12:36:52 -0500 | [diff] [blame] | 10 | inherit obmc-phosphor-dbus-service |
Vishwanatha Subbanna | 0489833 | 2017-01-09 16:02:27 +0530 | [diff] [blame] | 11 | |
| 12 | DEPENDS += "autoconf-archive-native" |
| 13 | DEPENDS += "sdbusplus" |
Xo Wang | e867f29 | 2017-03-14 16:40:31 -0700 | [diff] [blame] | 14 | DEPENDS += "phosphor-dbus-interfaces" |
Vishwanatha Subbanna | 0489833 | 2017-01-09 16:02:27 +0530 | [diff] [blame] | 15 | RDEPENDS_${PN} += "libsystemd" |
| 16 | |
Brad Bishop | 66038f4 | 2017-01-26 12:36:52 -0500 | [diff] [blame] | 17 | DBUS_SERVICE_${PN} += "xyz.openbmc_project.led.controller@.service" |
| 18 | |
Vishwanatha Subbanna | 0489833 | 2017-01-09 16:02:27 +0530 | [diff] [blame] | 19 | SRC_URI += "git://github.com/openbmc/phosphor-led-sysfs" |
Brad Bishop | 66038f4 | 2017-01-26 12:36:52 -0500 | [diff] [blame] | 20 | SRC_URI += "file://70-leds.rules" |
Andrew Geissler | 164e85b | 2018-10-30 20:20:24 +0000 | [diff] [blame] | 21 | SRCREV = "e0844ff447abad01fa6f902caab3839336d1518d" |
Vishwanatha Subbanna | 0489833 | 2017-01-09 16:02:27 +0530 | [diff] [blame] | 22 | S = "${WORKDIR}/git" |
Brad Bishop | 66038f4 | 2017-01-26 12:36:52 -0500 | [diff] [blame] | 23 | |
| 24 | do_install_append() { |
| 25 | install -d ${D}/${base_libdir}/udev/rules.d/ |
| 26 | install ${WORKDIR}/70-leds.rules ${D}/${base_libdir}/udev/rules.d/ |
| 27 | } |