Lei YU | 99cf05d | 2019-12-23 15:41:17 +0800 | [diff] [blame] | 1 | HOMEPAGE = "https://github.com/openbmc/phosphor-psu-code-mgmt" |
| 2 | LICENSE = "Apache-2.0" |
| 3 | LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=86d3f3a95c324c9479bd8986968f4327" |
| 4 | SRC_URI += "git://github.com/openbmc/phosphor-psu-code-mgmt" |
Andrew Geissler | b76ebf7 | 2020-06-15 03:41:49 +0000 | [diff] [blame] | 5 | SRCREV = "de27029319bf04250d7660976091b7c297ed3c41" |
Lei YU | 99cf05d | 2019-12-23 15:41:17 +0800 | [diff] [blame] | 6 | SUMMARY = "Phosphor PSU software manager" |
| 7 | DESCRIPTION = "Providing PSU firmware version and upgrade" |
| 8 | |
| 9 | PR = "r1" |
| 10 | PV = "1.0+git${SRCPV}" |
| 11 | |
| 12 | inherit meson |
| 13 | inherit pkgconfig |
| 14 | inherit obmc-phosphor-systemd |
| 15 | |
| 16 | S = "${WORKDIR}/git" |
| 17 | |
| 18 | DEPENDS = " \ |
| 19 | phosphor-logging \ |
| 20 | phosphor-dbus-interfaces \ |
| 21 | sdbusplus \ |
| 22 | openssl \ |
| 23 | " |
| 24 | |
| 25 | # The default config of this repo depends on utils from phosphor-power. |
| 26 | # If your system does not depend on phosphor-power, please use |
| 27 | # RDEPENDS_${PN}_remove to remove the dependency. |
| 28 | RDEPENDS_${PN} += "phosphor-power" |
| 29 | |
| 30 | # The below configs are expected to be overriden by machine layer |
| 31 | |
| 32 | ## The psutils here comes from phosphor-power repo where |
| 33 | ## * PSU_VERSION_UTIL accepts a PSU inventory path and returns the PSU |
| 34 | ## firmware version string |
| 35 | ## * PSU_VERSION_COMPARE_UTIL accepts several PSU inventory paths and return |
| 36 | ## the newest version string |
| 37 | PSU_VERSION_UTIL ?= "-DPSU_VERSION_UTIL='/usr/bin/psutils --raw --get-version'" |
| 38 | PSU_VERSION_COMPARE_UTIL ?= "-DPSU_VERSION_COMPARE_UTIL='/usr/bin/psutils --raw --compare'" |
| 39 | |
| 40 | ## The psu-update@.service from repo is an example service that only prints a log and fails |
| 41 | ## Override it in a machine layer to invoke the psu update util |
| 42 | PSU_UPDATE_SERVICE ?= "-DPSU_UPDATE_SERVICE=psu-update@.service" |
| 43 | |
| 44 | EXTRA_OEMESON = " \ |
| 45 | -Dtests=disabled \ |
| 46 | ${PSU_VERSION_UTIL} \ |
| 47 | ${PSU_VERSION_COMPARE_UTIL} \ |
| 48 | ${PSU_UPDATE_SERVICE} \ |
| 49 | " |
| 50 | |
| 51 | SYSTEMD_SERVICE_${PN} = "xyz.openbmc_project.Software.Psu.Updater.service" |
| 52 | SYSTEMD_SERVICE_${PN} += "psu-update@.service" |