blob: b8529378cbb3b6cad6a58829473cb0bf1f464856 [file] [log] [blame]
Tom Josephf2614f92017-05-08 11:49:10 +05301SUMMARY = "Inventory to Sensor config for phosphor-host-ipmi"
2PR = "r1"
3
4inherit native
5inherit obmc-phosphor-license
6inherit phosphor-ipmi-host
7
8SRC_URI += "file://config.yaml"
9
10DEPENDS += " \
11 mrw-native \
12 mrw-perl-tools-native \
13 "
14
15PROVIDES += "virtual/phosphor-ipmi-inventory-sel"
16
17S = "${WORKDIR}"
18
19do_install() {
20 DEST=${D}${sensor_datadir}
21 install -d ${DEST}
22
23 ${bindir}/perl-native/perl \
24 ${bindir}/gen_ipmi_sel.pl \
25 -i ${datadir}/obmc-mrw/${MACHINE}.xml \
26 -m config.yaml \
27 -o ${DEST}/invsensor.yaml
28}