Brad Bishop | 80fac6d | 2016-06-07 16:25:54 -0400 | [diff] [blame] | 1 | SUMMARY = "U-Boot bootloader fw_printenv/setenv utilities" |
| 2 | LICENSE = "GPLv2+" |
| 3 | LIC_FILES_CHKSUM = "file://Licenses/README;md5=a2c678cfd4a4d97135585cad908541c6" |
| 4 | SECTION = "bootloader" |
| 5 | DEPENDS = "mtd-utils" |
| 6 | |
Joel Stanley | 6e98af5 | 2017-01-18 11:04:45 +1100 | [diff] [blame] | 7 | SRCREV = "be5e3b5b680746718f45ec5ad45e2debc61407b5" |
Joel Stanley | 7741d65 | 2016-07-27 18:33:40 +0930 | [diff] [blame] | 8 | UBRANCH = "v2016.07-aspeed-openbmc" |
Brad Bishop | 80fac6d | 2016-06-07 16:25:54 -0400 | [diff] [blame] | 9 | SRC_URI = "git://git@github.com/openbmc/u-boot.git;branch=${UBRANCH};protocol=https" |
| 10 | |
Joel Stanley | 7741d65 | 2016-07-27 18:33:40 +0930 | [diff] [blame] | 11 | PV = "v2016.07+git${SRCPV}" |
Brad Bishop | 80fac6d | 2016-06-07 16:25:54 -0400 | [diff] [blame] | 12 | |
| 13 | S = "${WORKDIR}/git" |
| 14 | |
| 15 | INSANE_SKIP_${PN} = "already-stripped" |
| 16 | EXTRA_OEMAKE_class-target = 'CROSS_COMPILE=${TARGET_PREFIX} CC="${CC} ${CFLAGS} ${LDFLAGS}" V=1' |
| 17 | EXTRA_OEMAKE_class-cross = 'ARCH=${TARGET_ARCH} CC="${CC} ${CFLAGS} ${LDFLAGS}" V=1' |
| 18 | |
| 19 | inherit uboot-config |
| 20 | |
| 21 | do_compile () { |
| 22 | oe_runmake ${UBOOT_MACHINE} |
| 23 | oe_runmake env |
| 24 | } |
| 25 | |
| 26 | do_install () { |
| 27 | install -d ${D}${base_sbindir} |
| 28 | install -d ${D}${sysconfdir} |
| 29 | install -m 755 ${S}/tools/env/fw_printenv ${D}${base_sbindir}/fw_printenv |
| 30 | install -m 755 ${S}/tools/env/fw_printenv ${D}${base_sbindir}/fw_setenv |
| 31 | install -m 0644 ${S}/tools/env/fw_env.config ${D}${sysconfdir}/fw_env.config |
| 32 | } |
| 33 | |
| 34 | do_install_class-cross () { |
| 35 | install -d ${D}${bindir_cross} |
| 36 | install -m 755 ${S}/tools/env/fw_printenv ${D}${bindir_cross}/fw_printenv |
| 37 | install -m 755 ${S}/tools/env/fw_printenv ${D}${bindir_cross}/fw_setenv |
| 38 | } |
| 39 | |
| 40 | SYSROOT_PREPROCESS_FUNCS_class-cross = "uboot_fw_utils_cross" |
| 41 | uboot_fw_utils_cross() { |
| 42 | sysroot_stage_dir ${D}${bindir_cross} ${SYSROOT_DESTDIR}${bindir_cross} |
| 43 | } |
| 44 | |
| 45 | PACKAGE_ARCH = "${MACHINE_ARCH}" |
| 46 | BBCLASSEXTEND = "cross" |