Matt Spinler | 0b96a4e | 2016-08-12 12:52:36 -0500 | [diff] [blame] | 1 | SUMMARY = "Phosphor OpenBMC machine readable workbook API modules" |
| 2 | DESCRIPTION = "The API for the MRW XML generated by the Serverwiz tool" |
| 3 | PR = "r1" |
Patrick Venture | 7def530 | 2018-11-06 10:09:31 -0800 | [diff] [blame] | 4 | LICENSE = "Apache-2.0" |
Brad Bishop | 1795f38 | 2018-11-09 09:36:28 -0500 | [diff] [blame] | 5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=d2794c0df5b907fdace235a619d80314" |
Matt Spinler | 0b96a4e | 2016-08-12 12:52:36 -0500 | [diff] [blame] | 6 | |
Brad Bishop | 1795f38 | 2018-11-09 09:36:28 -0500 | [diff] [blame] | 7 | S = "${WORKDIR}/git" |
Matt Spinler | 0b96a4e | 2016-08-12 12:52:36 -0500 | [diff] [blame] | 8 | |
Matt Spinler | 0b96a4e | 2016-08-12 12:52:36 -0500 | [diff] [blame] | 9 | inherit native |
| 10 | inherit perlnative |
| 11 | inherit cpan-base |
Matt Spinler | de33cae | 2016-09-15 10:39:43 -0500 | [diff] [blame] | 12 | inherit mrw-rev |
Matt Spinler | 0b96a4e | 2016-08-12 12:52:36 -0500 | [diff] [blame] | 13 | |
| 14 | DEPENDS += "libxml-simple-perl-native json-perl-native" |
| 15 | |
Matt Spinler | de33cae | 2016-09-15 10:39:43 -0500 | [diff] [blame] | 16 | SRC_URI += "${MRW_API_SRC_URI}" |
| 17 | SRCREV = "${MRW_API_SRCREV}" |
Matt Spinler | 0b96a4e | 2016-08-12 12:52:36 -0500 | [diff] [blame] | 18 | |
| 19 | do_install() { |
Brad Bishop | 22ccb19 | 2019-02-01 08:06:28 -0500 | [diff] [blame] | 20 | install -d ${D}${PERLLIBDIRS_class-native}/site_perl/${PERLVERSION}/mrw |
| 21 | install -m 0755 scripts/Targets.pm ${D}${PERLLIBDIRS_class-native}/site_perl/${PERLVERSION}/mrw/Targets.pm |
Matt Spinler | 0b96a4e | 2016-08-12 12:52:36 -0500 | [diff] [blame] | 22 | } |