Brad Bishop | 9b1417f | 2015-09-21 17:16:16 -0400 | [diff] [blame] | 1 | SUMMARY = "Phosphor OpenBMC BSP Example Application" |
| 2 | DESCRIPTION = "Phosphor OpenBMC QEMU BSP example implementation." |
| 3 | PR = "r1" |
| 4 | |
Brad Bishop | a5983c9 | 2016-08-16 09:40:10 -0400 | [diff] [blame] | 5 | DBUS_SERVICE_${PN} += "org.openbmc.examples.PythonService.service" |
Brad Bishop | 9b1417f | 2015-09-21 17:16:16 -0400 | [diff] [blame] | 6 | |
| 7 | inherit obmc-phosphor-pydbus-service |
Brad Bishop | b2571e2 | 2015-09-21 22:01:13 -0400 | [diff] [blame] | 8 | |
| 9 | client = "pyclient-sample" |
| 10 | SRC_URI += "file://${client}.py" |
Brad Bishop | db6cd1b | 2015-10-18 22:00:15 -0400 | [diff] [blame] | 11 | SRC_URI += "file://${PN}.py" |
| 12 | S = "${WORKDIR}" |
Brad Bishop | b2571e2 | 2015-09-21 22:01:13 -0400 | [diff] [blame] | 13 | |
| 14 | do_install_append() { |
| 15 | install -d ${D}${bindir} |
Brad Bishop | db6cd1b | 2015-10-18 22:00:15 -0400 | [diff] [blame] | 16 | install -m 0755 ${S}/${client}.py ${D}${bindir}/${client} |
Brad Bishop | b2571e2 | 2015-09-21 22:01:13 -0400 | [diff] [blame] | 17 | } |