Matt Spinler | 0b96a4e | 2016-08-12 12:52:36 -0500 | [diff] [blame] | 1 | SUMMARY = "Phosphor OpenBMC machine readable workbook API modules" |
| 2 | DESCRIPTION = "The API for the MRW XML generated by the Serverwiz tool" |
| 3 | PR = "r1" |
| 4 | |
| 5 | S = "${WORKDIR}/scripts" |
| 6 | |
| 7 | inherit obmc-phosphor-license |
| 8 | inherit native |
| 9 | inherit perlnative |
| 10 | inherit cpan-base |
| 11 | |
| 12 | DEPENDS += "libxml-simple-perl-native json-perl-native" |
| 13 | |
| 14 | SRC_URI += "git://github.com/open-power/serverwiz.git;subpath=scripts" |
| 15 | SRCREV = "04f15f37e9ab6c09412a0abcffb87e9aefcc5368" |
| 16 | |
| 17 | do_install() { |
| 18 | install -d ${PERLLIBDIRS_class-native}/perl/site_perl/${PERLVERSION}/mrw |
| 19 | install -m 0755 Targets.pm ${PERLLIBDIRS_class-native}/perl/site_perl/${PERLVERSION}/mrw/Targets.pm |
| 20 | } |