blob: 3a0449841d73f65c4315a38ea4a0dffa801c77ec [file] [log] [blame]
Vishwanatha Subbanna7e84c6e2017-01-23 16:04:35 +05301SUMMARY = "Phosphor LED Group Management meta data"
2PR = "r1"
3
4inherit obmc-phosphor-utils
5inherit obmc-phosphor-license
6
7# Default is the example set of data.
8PHOSPHOR_LED_MANAGER_CONFIG ??= "${PN}-example-native"
9
10# Choose appropriate yaml file
11def get_depends(d):
12 if d.getVar('USE_MRW', 'yes'):
13 return "${PN}-mrw-native"
14 else:
15 return "${PHOSPHOR_LED_MANAGER_CONFIG}"
16
17USE_MRW = "${@cf_enabled('obmc-mrw', 'yes', d)}"
18DEPENDS += "${@get_depends(d)}"