blob: dcc5bd3c15de7def46aff6cb9f6485bf8a7450f5 [file] [log] [blame]
Brad Bishopf8a7cd12017-07-09 23:41:49 -04001SUMMARY = "Phosphor Mapper Configuration"
2DESCRIPTION = "Meta-recipe, pulling in native recipes that wish to add \
3configuration files to the native /usr/share/phosphor-mapper filesystem."
4HOMEPAGE = "http://github.com/openbmc/phosphor-objmgr"
5PR = "r1"
6
7inherit obmc-phosphor-license
8inherit native
9inherit phosphor-mapper
10
11PHOSPHOR_MAPPER_CONFIGS = " \
12 phosphor-dbus-interfaces-mapper-config-native \
13 phosphor-legacy-namespace-mapper-config-native \
14 "
15
16DEPENDS += "${PHOSPHOR_MAPPER_CONFIGS}"
17
18# To add namespaces and blacklists to the mapper configuration,
19# create a native recipe in your layer, and add it to
20# PHOSPHOR_MAPPER_CONFIGS with a bbappend to this recipe.
21# Recipes should set one of the variables below.
22# Consult phosphor-mapper.bbclass for additional information.
23
24# Add path namespaces to be monitored.
25PHOSPHOR_MAPPER_NAMESPACE = ""
26
27# Add interfaces to be monitored.
28PHOSPHOR_MAPPER_INTERFACE = ""
29
Brad Bishopf8a7cd12017-07-09 23:41:49 -040030do_install() {
31 install -d ${D}/${namespace_dir}
32 install -d ${D}/${interface_dir}
Brad Bishopf8a7cd12017-07-09 23:41:49 -040033}