blob: a4dcfab3d5a06787533f20a84b010284403ee51a [file] [log] [blame]
Chris Austenf7cefb12015-11-01 22:27:34 -06001SUMMARY = "Phosphor OpenBMC WriteFRU for OpenPOWER systems"
2DESCRIPTION = "Phosphor OpenBMC WriteFRU for OpenPOWER based systems"
3HOMEPAGE = "https://github.com/openbmc/ipmi-fru-parser"
4PR = "r1"
5
6RRECOMMENDS_${PN} = "virtual/obmc-phosphor-host-ipmi-hw"
7
8inherit obmc-phosphor-license
9
10DEPENDS += "systemd \
11 host-ipmid \
12 "
13
14
15RDEPENDS_${PN} += "libsystemd"
16
17TARGET_CFLAGS += "-std=gnu++14"
18
19SRC_URI += "git://github.com/openbmc/ipmi-fru-parser"
20
21SRCREV = "675272789d4dba9a8c308f3cb1f7deb8b5b2ec41"
22
23FILES_${PN} += "${libdir}/host-ipmid/*.so"
24FILES_${PN}-dbg += "${libdir}/host-ipmid/.debug"
25
26S = "${WORKDIR}/git"
27
28do_install() {
29 install -m 0755 -d ${D}${libdir}/host-ipmid
30 install -m 0755 ${S}/*.so ${D}${libdir}/host-ipmid/
31}