blob: d0025793657e8005c05e259fce786cdad7cfb1ce [file] [log] [blame]
Jayanth Othayoth9963d172017-05-08 09:25:05 -05001SUMMARY = "Phosphor Debug Collector"
2DESCRIPTION = "Phosphor Debug Collector provides mechanisms \
3to collect various FFDC files and system parameters. \
4This will be helpful for troubleshooting the problems in OpenBMC \
5based systems."
6
7PR = "r1"
8
Jayanth Othayoth9d21d6c2017-05-31 06:25:55 -05009DEBUG_COLLECTOR_PKGS = " \
10 ${PN}-manager \
11 ${PN}-monitor \
12"
13PACKAGES =+ "${DEBUG_COLLECTOR_PKGS}"
14PACKAGES_remove = "${PN}"
15RDEPENDS_${PN}-dev = "${DEBUG_COLLECTOR_PKGS}"
16RDEPENDS_${PN}-staticdev = "${DEBUG_COLLECTOR_PKGS}"
17
18DBUS_PACKAGES = "${PN}-manager"
19
20SYSTEMD_PACKAGES = "${PN}-monitor"
21
Jayanth Othayoth9963d172017-05-08 09:25:05 -050022inherit autotools \
23 pkgconfig \
Jayanth Othayothaae91e32017-06-05 03:10:00 -050024 obmc-phosphor-dbus-service \
Jayanth Othayoth5f6d8852017-07-05 10:31:16 -050025 pythonnative \
26 phosphor-debug-collector
Jayanth Othayoth9963d172017-05-08 09:25:05 -050027
28require phosphor-debug-collector.inc
29
30DEPENDS += " \
31 phosphor-dbus-interfaces \
32 phosphor-dbus-interfaces-native \
33 phosphor-logging \
34 sdbusplus \
35 sdbusplus-native \
36 autoconf-archive-native \
Jayanth Othayoth9d21d6c2017-05-31 06:25:55 -050037"
Jayanth Othayoth9963d172017-05-08 09:25:05 -050038
Jayanth Othayoth9d21d6c2017-05-31 06:25:55 -050039RDEPENDS_${PN}-manager += " \
Jayanth Othayoth9963d172017-05-08 09:25:05 -050040 sdbusplus \
41 phosphor-dbus-interfaces \
42 phosphor-logging \
Jayanth Othayoth9d21d6c2017-05-31 06:25:55 -050043"
44RDEPENDS_${PN}-monitor += " \
45 sdbusplus \
46 phosphor-dbus-interfaces \
47 phosphor-logging \
48"
Jayanth Othayoth9963d172017-05-08 09:25:05 -050049
Jayanth Othayoth5f6d8852017-07-05 10:31:16 -050050MGR_SVC ?= "xyz.openbmc_project.Dump.Manager.service"
51
52SYSTEMD_SUBSTITUTIONS += "BMC_DUMP_PATH:${bmc_dump_path}:${MGR_SVC}"
53
Jayanth Othayoth9d21d6c2017-05-31 06:25:55 -050054FILES_${PN}-manager += "${sbindir}/phosphor-dump-manager"
55FILES_${PN}-monitor += "${sbindir}/phosphor-dump-monitor"
56
Jayanth Othayoth5f6d8852017-07-05 10:31:16 -050057DBUS_SERVICE_${PN}-manager += "${MGR_SVC}"
Jayanth Othayoth9d21d6c2017-05-31 06:25:55 -050058SYSTEMD_SERVICE_${PN}-monitor += "obmc-dump-monitor.service"
Jayanth Othayoth9963d172017-05-08 09:25:05 -050059
Jayanth Othayothf1b85172017-07-05 10:54:35 -050060EXTRA_OECONF = "BMC_DUMP_PATH=${bmc_dump_path}"
Jayanth Othayoth5f6d8852017-07-05 10:31:16 -050061
Jayanth Othayoth9963d172017-05-08 09:25:05 -050062S = "${WORKDIR}/git"