blob: de4d6ba4199de3ff7620877940368663c37cb2a0 [file] [log] [blame]
Patrick Williams7aba8152020-03-31 14:22:32 -05001inherit obmc-phosphor-python-autotools
2include sdbus++.inc
3
Patrick Williams07ce0de2020-04-01 10:15:29 -05004SRC_URI += "file://0001-Revert-sdbus-switch-to-python3.patch"
5
Patrick Williams7aba8152020-03-31 14:22:32 -05006# Provide these aliases temporarily until everyone can move over to the
7# new package name.
8PROVIDES_class-native += "sdbusplus-native sdbus++-native"
9PROVIDES_class-nativesdk += "sdbusplus-nativesdk sdbus++-nativesdk"
Patrick Williams737cd1a2020-04-01 10:04:17 -050010
11# If anyone wanted the sdbus++ executable, make them use the python3 version.
12# This avoids issues where both packages attempt to install the executable
13# into /usr/bin.
14DEPENDS += "python3-sdbus++-native"
15do_install_append() {
16 rm ${D}${bindir}/sdbus++
17 rmdir ${D}${bindir} || true
18}