Brad Bishop | 86ee1cf | 2016-06-27 14:53:52 -0400 | [diff] [blame] | 1 | SUMMARY = "OpenBMC org.openbmc.Led example implementation" |
| 2 | DESCRIPTION = "A sample implementation for the org.openbmc.Led DBUS API. \ |
| 3 | The org.openbmc.Led provides APIs for controlling LEDs." |
| 4 | PR = "r1" |
| 5 | |
| 6 | inherit skeleton-sdbus |
Brad Bishop | 0fe8046 | 2016-08-17 20:27:37 -0400 | [diff] [blame] | 7 | inherit obmc-phosphor-dbus-service |
Brad Bishop | 86ee1cf | 2016-06-27 14:53:52 -0400 | [diff] [blame] | 8 | |
| 9 | RDEPENDS_${PN} += "libsystemd" |
| 10 | |
| 11 | SKELETON_DIR = "ledctl" |
Brad Bishop | 0fe8046 | 2016-08-17 20:27:37 -0400 | [diff] [blame] | 12 | DBUS_SERVICE_${PN} += "org.openbmc.control.led.service" |
| 13 | SYSTEMD_SERVICE_${PN} += "obmc-led-start@.service obmc-led-stop@.service" |