Matt Spinler | 3578d90 | 2018-06-21 14:23:47 -0500 | [diff] [blame] | 1 | SUMMARY = "Copy error yaml files to known path for elog parsing" |
| 2 | PR = "r1" |
| 3 | LICENSE = "Apache-2.0" |
| 4 | LIC_FILES_CHKSUM = "file://${PHOSPHORBASE}/COPYING.apache-2.0;md5=34400b68072d710fecd0a2940a0d1658" |
| 5 | |
| 6 | inherit native |
| 7 | inherit phosphor-dbus-yaml |
| 8 | |
| 9 | require phosphor-software-manager.inc |
| 10 | |
| 11 | S = "${WORKDIR}/git" |
| 12 | |
| 13 | do_install_append() { |
| 14 | SRC=${S}/xyz/openbmc_project/Software/ |
| 15 | DEST=${D}${yaml_dir}/xyz/openbmc_project/Software/ |
| 16 | install -d ${DEST} |
| 17 | install ${SRC}/*.errors.yaml ${DEST} |
| 18 | install ${SRC}/*.metadata.yaml ${DEST} |
| 19 | } |