blob: 7e3e90713c45bc62b641080bf2f3bbbefc8d00ec [file] [log] [blame]
Brad Bishop9b1417f2015-09-21 17:16:16 -04001SUMMARY = "Phosphor OpenBMC BSP Example Application"
2DESCRIPTION = "Phosphor OpenBMC QEMU BSP example implementation."
3PR = "r1"
4
Brad Bishopff7dc1d2016-07-13 17:56:34 -04005DBUS_SERVICE_${PN} += "org.openbmc.examples.PythonService"
Brad Bishop9b1417f2015-09-21 17:16:16 -04006
7inherit obmc-phosphor-pydbus-service
Brad Bishopb2571e22015-09-21 22:01:13 -04008
9client = "pyclient-sample"
10SRC_URI += "file://${client}.py"
Brad Bishopdb6cd1b2015-10-18 22:00:15 -040011SRC_URI += "file://${PN}.py"
12S = "${WORKDIR}"
Brad Bishopb2571e22015-09-21 22:01:13 -040013
14do_install_append() {
15 install -d ${D}${bindir}
Brad Bishopdb6cd1b2015-10-18 22:00:15 -040016 install -m 0755 ${S}/${client}.py ${D}${bindir}/${client}
Brad Bishopb2571e22015-09-21 22:01:13 -040017}