Add SOC update script
Need feed SOC update file name and TFTP IP
Tested: Built and validated a centriq2400 image
Change-Id: I74bf979c5c1e97aa25ea6f11b83831363041aa4d
Signed-off-by: Ken Chen <chen.kenyy@inventec.com>
diff --git a/meta-centriq2400-rep/recipes-phosphor/socupdate/socupdate.bb b/meta-centriq2400-rep/recipes-phosphor/socupdate/socupdate.bb
new file mode 100644
index 0000000..45f69d3
--- /dev/null
+++ b/meta-centriq2400-rep/recipes-phosphor/socupdate/socupdate.bb
@@ -0,0 +1,13 @@
+SUMMARY = "Qualcomm SOC update"
+DESCRIPTION = ""
+HOMEPAGE = ""
+PR = "r1"
+
+inherit obmc-phosphor-license
+
+SRC_URI += "file://socupdate.sh"
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 0755 ${WORKDIR}/socupdate.sh ${D}${bindir}/socupdate.sh
+}