Ken Chen | b65f37e | 2018-01-15 14:36:21 +0800 | [diff] [blame] | 1 | SUMMARY = "Qualcomm Rep board wiring" |
| 2 | DESCRIPTION = "Board wiring information for the Qualcomm Rep system." |
| 3 | PR = "r1" |
| 4 | |
| 5 | inherit allarch |
| 6 | inherit setuptools |
| 7 | inherit pythonnative |
| 8 | inherit obmc-phosphor-license |
| 9 | |
| 10 | PROVIDES += "virtual/obmc-inventory-data" |
| 11 | RPROVIDES_${PN} += "virtual-obmc-inventory-data" |
| 12 | |
| 13 | DEPENDS += "python" |
| 14 | |
| 15 | S = "${WORKDIR}" |
| 16 | SRC_URI += "file://Centriq2400-rep.py" |
| 17 | |
| 18 | python() { |
| 19 | machine = d.getVar('MACHINE', True).capitalize() + '.py' |
| 20 | d.setVar('_config_in_skeleton', machine) |
| 21 | } |
| 22 | |
| 23 | do_make_setup() { |
| 24 | cp ${S}/${_config_in_skeleton} \ |
| 25 | ${S}/obmc_system_config.py |
| 26 | cat <<EOF > ${S}/setup.py |
| 27 | from distutils.core import setup |
| 28 | |
| 29 | setup(name='${BPN}', |
| 30 | version='${PR}', |
| 31 | py_modules=['obmc_system_config'], |
| 32 | ) |
| 33 | EOF |
| 34 | } |
| 35 | |
| 36 | addtask make_setup after do_patch before do_configure |
| 37 | |