blob: 85c2e93b0e2b536514d359130d36389f33eb5bdf [file] [log] [blame]
Ken Chenfd74c192018-01-30 09:51:50 +08001SUMMARY = "centriq2400 VR sensor Re-Probe"
2DESCRIPTION = "IR38163 work on DC on state, need re-probe for centriq2400 HW design"
3PR = "r0"
4
5inherit obmc-phosphor-systemd
6inherit obmc-phosphor-license
7
8PROVIDES += 'virtual/ir38163-workaround'
9RPROVIDES_${PN} += 'virtual-ir38163-workaround'
10
11IR_REMOVE = "ir-remove@.service"
12IR_ADD = "ir-add@.service"
13INSTIR_REMOVE = "ir-remove@{0}.service"
14INSTIR_ADD = "ir-add@{0}.service"
15TGTFMT_OFF = "obmc-chassis-poweroff@{0}.target"
16TGTFMT_ON = "obmc-chassis-poweron@{0}.target"
17FMT_REMOVE = "../${IR_REMOVE}:${TGTFMT_OFF}.wants/${INSTIR_REMOVE}"
18FMT_ADD = "../${IR_ADD}:${TGTFMT_ON}.requires/${INSTIR_ADD}"
19
20SYSTEMD_SERVICE_${PN} += "${IR_REMOVE}"
21SYSTEMD_LINK_${PN} += "${@compose_list(d, 'FMT_REMOVE', 'OBMC_CHASSIS_INSTANCES')}"
22SYSTEMD_SERVICE_${PN} += "${IR_ADD}"
23SYSTEMD_LINK_${PN} += "${@compose_list(d, 'FMT_ADD', 'OBMC_CHASSIS_INSTANCES')}"
24
25SRC_URI += "file://ir38163_workaround.sh"
26
27do_install() {
28 install -d ${D}${bindir}
29 install -m 0755 ${WORKDIR}/ir38163_workaround.sh ${D}${bindir}/ir38163_workaround.sh
30}