blob: fd02327f1cf63c01a860b342348b25c376f96a10 [file] [log] [blame]
Patrick Venturec8eec652017-04-10 15:21:32 -07001FILESEXTRAPATHS_append := "${THISDIR}/files:"
2
3inherit systemd
4inherit obmc-phosphor-license
5inherit obmc-phosphor-systemd
6
7S = "${WORKDIR}/"
8
9SRC_URI = "file://init_once.sh \
10 file://poweroff.sh \
11 file://poweron.sh \
12 file://host-gpio.service \
13 file://host-poweroff.service \
14 file://host-poweron.service"
15
16DEPENDS = "systemd"
17RDEPENDS_${PN} = "bash"
18
19SYSTEMD_PACKAGES = "${PN}"
20SYSTEMD_SERVICE_${PN} = "host-gpio.service host-poweron.service host-poweroff.service"
21
22do_install() {
23 install -d ${D}/usr/sbin
24 install -m 0755 ${S}init_once.sh ${D}/${sbindir}/
25 install -m 0755 ${S}poweroff.sh ${D}/${sbindir}/
26 install -m 0755 ${S}poweron.sh ${D}/${sbindir}/
27}