blob: 68a9cf1814051e28f34571511a1b17a6ba54e272 [file] [log] [blame]
George Hung3a9aa272020-06-19 19:45:43 +08001SUMMARY = "Phosphor OpenBMC Quanta GBS System Initialization Service"
2DESCRIPTION = "Phosphor OpenBMC Quanta GBS System Init"
3PR = "r1"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
6
7inherit systemd
8
9DEPENDS += "systemd"
10RDEPENDS_${PN} += "bash"
11RDEPENDS_${PN} += "libsystemd"
12RDEPENDS_${PN} += "jq"
13
14SRC_URI = "file://gbs-sysinit.sh \
15 file://gbs-gpio-common.sh \
16 file://gbs-sysinit.service \
17 "
18
19do_install () {
20 install -d ${D}${bindir}
21 install -m 0755 ${WORKDIR}/gbs-sysinit.sh ${D}${bindir}/
22
23 install -d ${D}${libexecdir}
24 install -m 0755 ${WORKDIR}/gbs-gpio-common.sh ${D}${libexecdir}/
25
26 install -d ${D}${systemd_system_unitdir}
27 install -m 0644 ${WORKDIR}/gbs-sysinit.service ${D}${systemd_system_unitdir}
28}
29
30SYSTEMD_PACKAGES = "${PN}"
31SYSTEMD_SERVICE_${PN} = "gbs-sysinit.service"