George Hung | b67a01a | 2020-06-30 10:47:30 +0800 | [diff] [blame] | 1 | PR = "r1" |
| 2 | LICENSE = "Apache-2.0" |
| 3 | LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10" |
| 4 | |
| 5 | SRC_URI = "git://github.com/quanta-bmc/read-margin-temp.git" |
| 6 | SRCREV = "1a74891c996725dd4c94397d2588d840da07c548" |
| 7 | S = "${WORKDIR}/git" |
| 8 | |
| 9 | SRC_URI += " file://config-margin.json \ |
| 10 | file://read-margin-temp-wait.sh \ |
| 11 | " |
| 12 | |
| 13 | inherit autotools pkgconfig |
| 14 | inherit meson |
| 15 | |
| 16 | DEPENDS += " nlohmann-json" |
| 17 | DEPENDS += " sdbusplus" |
| 18 | DEPENDS += " sdbusplus-native" |
| 19 | DEPENDS += " sdeventplus" |
| 20 | DEPENDS += " phosphor-dbus-interfaces" |
| 21 | |
| 22 | RDEPENDS_${PN} += " bash" |
| 23 | |
| 24 | FILES_${PN} = "${bindir}/read-margin-temp" |
| 25 | FILES_${PN} += " ${bindir}/read-margin-temp-wait.sh" |
| 26 | FILES_${PN} += " ${datadir}/read-margin-temp/config-margin.json" |
| 27 | |
| 28 | do_install() { |
| 29 | install -d ${D}${bindir} |
| 30 | install -m 0755 read-margin-temp ${D}${bindir} |
| 31 | install -m 0755 ${WORKDIR}/read-margin-temp-wait.sh ${D}/${bindir} |
| 32 | |
| 33 | install -d ${D}${datadir}/read-margin-temp |
| 34 | install -m 0644 -D ${WORKDIR}/config-margin.json \ |
| 35 | ${D}${datadir}/read-margin-temp/config-margin.json |
| 36 | |
| 37 | } |