blob: 318c03f4f16146d7151df6c6a010d9cccdddc10b [file] [log] [blame]
George Hung41dd1472020-06-11 21:11:09 +08001SUMMARY = "NVMe Drives Power Control"
2DESCRIPTION = "Daemon to monitor and control the power of NVMe drives"
3PR = "r1"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
6
7inherit meson pkgconfig
8inherit systemd
9
10DEPENDS += "sdbusplus"
11DEPENDS += "boost"
12DEPENDS += "libgpiod"
13
14SRC_URI = "git://github.com/quanta-bmc/nvme-power-control;protocol=git"
15SRCREV = "9bc98c2de5d9ae367e450a8acc4b6cf0c3a3dd63"
16
17S = "${WORKDIR}/git"
18
19SYSTEMD_SERVICE_${PN} = "xyz.openbmc_project.Control.Nvme.Power.service"