blob: 330cda177c58cbacb12cb89c9332f450e2c742f8 [file] [log] [blame]
Patrick Venture44b67f52018-04-13 13:41:52 -07001inherit native
2inherit obmc-phosphor-license
3
4DEPENDS += "virtual/phosphor-ipmi-fru-inventory"
5PROVIDES += "virtual/phosphor-ipmi-fru-merge-config"
6
7# Put the fru_config in the right place with the right name.
8# Pull the IPMI FRU YAML config to use it in the IPMI HOST YAML.
9do_install_append() {
10 IPMI_FRU_SRC=${datadir}/phosphor-ipmi-fru/config
11 IPMI_HOST_DEST=${D}${datadir}/phosphor-ipmi-host/config
12 install -d ${IPMI_HOST_DEST}
13 cat ${IPMI_FRU_SRC}/config.yaml > ${IPMI_HOST_DEST}/fru_config.yaml
14}