Patrick Venture | 7642894 | 2017-05-09 10:04:13 -0700 | [diff] [blame] | 1 | SUMMARY = "FRU properties config for ipmi-fru-parser" |
| 2 | PR = "r1" |
| 3 | |
| 4 | inherit native |
| 5 | inherit obmc-phosphor-license |
| 6 | inherit phosphor-ipmi-fru |
| 7 | |
| 8 | SRC_URI += "file://extra-properties.yaml" |
| 9 | |
| 10 | PROVIDES += "virtual/phosphor-ipmi-fru-properties" |
| 11 | |
| 12 | S = "${WORKDIR}" |
| 13 | |
| 14 | do_install() { |
| 15 | # TODO: install this to inventory_datadir |
| 16 | # after ipmi-fru-parser untangles the host |
| 17 | # firmware config from the machine inventory. |
| 18 | DEST=${D}${properties_datadir} |
| 19 | |
| 20 | install -d ${DEST} |
| 21 | install extra-properties.yaml ${DEST}/. |
| 22 | } |
| 23 | |