blob: fd5819d42cbe908f173e5b90b8786666e10b871b [file] [log] [blame]
George Hunga8f1a522020-08-03 13:39:03 +08001PR = "r1"
2PV = "1.0+git${SRCPV}"
3LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
5
6SRC_URI = "git://github.com/quanta-bmc/read-margin-temp.git"
7SRCREV = "ca2dc1bf7f34d517f0edc59dd3596c3a76c3d7a1"
8S = "${WORKDIR}/git"
9
10inherit autotools pkgconfig
11inherit meson
12
13DEPENDS += " nlohmann-json"
14DEPENDS += " sdbusplus"
George Hunga8f1a522020-08-03 13:39:03 +080015DEPENDS += " sdeventplus"
16DEPENDS += " phosphor-dbus-interfaces"
17RDEPENDS_${PN} += " bash"
18
19FILES_${PN} = "${bindir}/read-margin-temp"
20
21do_install() {
22 install -d ${D}${bindir}
23 install -m 0755 read-margin-temp ${D}${bindir}
24}
25